Jump to content

MagicQ PC - remote control setup


Recommended Posts

Having swapped the computer my Maxi Wing runs on, I was trying to set up the networking so that I could use an iphone and ipad, but was getting very frustrated. The downloaded sheets I printed out wanted me to change the router's IP address range (which I didn't remember doing before) and my BT router was quite resistive to this, requiring many reboots. After spending hours attempting to follow the instructions and putting the pad and phone onto a different IP range - st5arting with the MagicQ's default '2', I was about to give up - neither device seeing the lighting control PC - until I noticed the 'enable remote control' setting in multi console - which, once enabled lat both devices connect without changing any of the defaults, or requiring the router to work on settings it did not like.


If anyone else ever has trouble - this turn on feature doesn't get much/any mention in the instructions.

Link to comment
Share on other sites

You don't need to change routers IP address range. Everything just needs to be in the same range. Many consumer routers don't even allow changing that range to that 2.x.x.x because they are locked to Class C.


Remote app config


1. MagicQ Remote Application -> last paragraph:


To enable support for the remote application, set Setup, View Settings, Multi Console, Remote Control to "Enabled".

Link to comment
Share on other sites

a different IP range - st5arting with the MagicQ's default '2',


The range "2.x.x.x" is that of ArtNet, so it may be that it is the default for sending out DMX in this manner.


I am currently having a drama setting up MA console remote because my consoles and router are in the ArtNet range for sending DMX to the media servers but the remote will apparently only run in 192.168.x.x and the support available is fairly limited.

Link to comment
Share on other sites

Set an additional network up in the router, so your LAN has two sets of addresses on it and the router will route between them.


Using can be poblematic, as it is a "proper" IP address, assigned to real entities, and thus iof one uses it locally one cannot get to thoise addresses on the internet. More than that, if one does use an internet connected router, one really ought to put a filter on it to stop from getting in from / out to the Internet.



1. Don't use ArtNet at all, use streaming ACN

2. Use for ArtNet. (not all devices support this, though they should)

3. Confugure networking carefully and hope for best.


E2A - A better solution is for the console to have two IP addresses, so it uses (for example) 192.168.something.0/24 for the iPads and other remote stuff, and or for ArtNet, and no routing between the two. Any console that has and underlying "proper" operating system should be able to be configured this way, though whether the console manufacturer has exposed these choices is up to that console manufacturer. If yours doesn't, complain!

Link to comment
Share on other sites

Networking is always a mystery to me - we've got 9 here, and every single one sees different machines on the network. It's obviously me, but maybe it's asking a lot for windows 7 and 8 computers to actually talk to each other without outside intervention?


The blurb on MagicQ does point out that the router, the mobiles and MagicQ should be on the same IP range, with the default coming up on screen as a '2' address. The fact it works fine without doing the change to '2' is a tad annoying. Now everything is working, of course I'm happy - but I was a minute, I reckon, from giving up.

Link to comment
Share on other sites

I'll be honest. I've never struggled to get machines talking to each-other. Windows (XP, Vista, 7, 8), Linux, OSX and embedded devices.


Generally, getting everything on the same subnet ( and IP Range 10.*.*.* lets me ping between everything pretty much instantly. When using fixed IPs everything is a bit easier as just a simple network switch is needed.


Firewalls can cause issues with software talking to other machines. I find that machines where I can control their entire network environment (Laptops for show use only) I just disable the firewall. On machines where I need to make them public, firewall rules which allow traffic on a specific range of IP Addresses (or a Subnet) are needed.


Software such as MagicQ (and Titan IIRC) require the IP Address in the software to be set equal to the IP Address on the operating system before they can work. This can stem from them ignoring packets not sent to the "correct" IP Address.


Getting Windows computers to show up and be accessible to each-other on a Windows network requires a grasp of privileges, domains and Windows sharing settings which can be less than straightforward.


Maybe a few "getting started with networking in entertainment" guides would be handy?




Link to comment
Share on other sites

The fact it works fine without doing the change to '2' is a tad annoying.


That setting doesn't work because MagicQ PC software can't change your computer ip address. Your MagicQ IP address is same as your computer IP address. You have to go to your computer network settings to change ip address (or let the router do the job with DHCP).


If you are using console e.g. Mq100, you have to fill in the right IP range to get remote working.




Link to comment
Share on other sites

It's obviously me, but maybe it's asking a lot for windows 7 and 8 computers to actually talk to each other without outside intervention?


W/7 (and W/8) computers will happily talk to each other and to the internet without any problems at all, and will do it all by themselves in any legal, valid network setting.


The problem isn't you - it's ArtNet. If you just don't use ArtNet everything will be A-OK.


By default, most internet routers will assume yopu want a private network on a 192.168.something.0/24 address range, and any normal computer will find that through DCHP and all will be hunky dory. If yoiu just connect a few W/7 PCs, without a router, they'll work that out, and assign a bunch of valid addresses amongsth themselves and that'll work too.


If you can use ArtNet on then that works too; you either need a router (or something that can support DHCP, not necessarily internet) set to work on, or you need to maually configure your PCs and other things on addresses starting 10.<something>.<something>.<something> with a subnet mask of and they'll all work too. Just like Josh notes above.


If you need to use ArtNet on, then the pain goes up.


So the messgae is - don't use ArtNet. If everyone stopped using ArtNet the world would be a better place. It really is that simple, and that is true and factual. ArtNet was designed by preople who either knew the square root of f**k all about networking, or worse, actually did understand networking and simply didn't give a flying f**k about interoperability or the Internet. Either way, they did a sh*t job. People - stop using ArtNet - use ACN.

Link to comment
Share on other sites

I didn't get from Paul's OP that ArtNet is the issue. The MQ remote control is, I believe, using a proprietory protocol and as mentioned needs enabling via the settings.


Again as already said, when using a PC version remember that the IP in MQ settings is not automatically that of the OS.


Once you know the very basics of networking and IPs it is easy enough to set up. Test by pinging from the MQ command line > ping etc. I like static IPs for all show control because I find it easier in a small enough system. Our Tech Dem is a network nerd and uses DCHP for a lot of our system at uni.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.