Jump to content

Broken Scrollers (Gelstream)


Recommended Posts

Hi all,


Hopefully somebody here will be able to help!


I've got a couple of broken Gelstream scrollers in my garage, which belong to a friend, which I've finally got round to looking at! I was wondering if somebody here would be able to help shed some light for me.


I've got the Gelstream manual, but it doesn't have any detailed schematics or anything inside - the only thing it shows of any use is how to re-string it!


Anyway onto the problems:


Scroller 1 - The trim pot is broken. Other than that the scroller works fine, although when a full length scroll is placed in only up to frame 8 or so can be used. Turning the trim pot does nothing. I've tried re-soldering it on to the board but that hasn't helped. Is it likely to be just simply the pot (so I could get another and solder it in) or is there something else down the line?


Scroller 2 - Does nothing. I was using it for a show and I can only assume it got jammed and something, somewhere, burnt out. It certainly had a horrible smell when taken down from the grid! I've tried replacing the main fuse, as the last one looked blown, but this hasn't helped at all. No lights come on under the unit. Power supply problem? If so - can another one just be bought and dunked in?


If anybody has any info or suggestions at all that would be much appreciated.







Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.