Jump to content

goldenscan lamping problem

lee weathers

Recommended Posts

I think it's a fairly safe bet that the lamp isn't striking if the OP has tried looking at the items listed.


To the OP have you metered the input side of the ignitor to make sure that mains is getting there (NOTE: Don't try and meter the output side else you'll have a toasted meter amongst other things!) I can't remember if there is a relay in the lamp circuit on Goldenscans, this could be your problem but would be identifiable if there was no mains to the lamp circuit. If there is no mains at the ignitor check for mains at the input and output of the ballast. As this is the only other thing you haven't checked in the lamp circuit then it's feasible this is the problem.

Link to comment
Share on other sites



Have you tried rotating the lamp so that the arc flows from the opposite electrode? They tend to burn unevenly on those type of lamps.


Agree with the others though, you clearly do have a problem with at least one of the above in your list, because it would be working otherwise. IIRC HPE's dont have a lamp relay, the cutoff switch is directly wired to the primary of the ballast, so, with the power off, check that the contacts are closing.


All the best


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.