Jump to content

Martin 218 Roboscan MKII tilt fault


Recommended Posts

I have 12 Martin 218 MkII scanners, which would be all well and good other than 5 of them have developed an identical fault (well, I say developed, most of them had it when I got them, though those were bought as spears!). The mirror tilt moves like it has got 2 steps missing (so it sort of dose what it’s supposed to but is very jerky about it). Its not the motor/cable loom, stepper driver chip (well, we tried changing it and the fixture still had an identical fault when we put it back together), or main processor/control chips as I have tried swapping them all for ones I know work, its also not a DMX fault as it dose all this when running on stand alone or resetting.


Seems as I have over 1/3rd of my units have the same fault I would have thought it would be a well known one, but martin didn’t seem to know and can’t find anything on the net. The things we have left to try are the surface mount DA converters and the surface mount resistors around the stepper driver chip, but seems as this is not a job im looking forward to I thought I would see if any of you good people have come across this fault and or have any ideas how we might be able to fix it!

Link to comment
Share on other sites

Have you actually changed the tilt motor cables or just buzzed them through? They can partially fail as they move then make contact again. You can swap the tilt motor plug with the colour motor plug for example to prove a point (of course they will act weirdly but should narrow it down.) The other main problem I remember from these oldies is rotting tracks underneath certain IC's. The pcb tracks seem susceptible to a mixture of sweat and smoke fluid and fag smoke and can slowly corrode where you cant see it trapped The outputs are strobed from the processor and so a duff motor phase can result from a rotted track anywhere on the board!


You sometimes get leaky darlington driver input capacitors (surface mount) but I've only had this on Robe and not Martin.


Your best bet is to put it in test mode and trace the phases with an oscilloscope back to the CPU output port IC.

Link to comment
Share on other sites

  • 6 months later...

I think I have a similar problem with a unit. Did you ever resolve this issue or does anyone else have any further suggestions?


Is it possible to fit mk1 control cards into a mk2 head?


If so, does anyone know which way round the connectors on the mk1 control board are as they are not labelled and differ in layout from the mk2s?


Clearly I can just plug motors in one by one and find out but asking is going to be quicker.

Link to comment
Share on other sites

Guest joewhite903

One thing I would sujest and be careful when doing so.

Open up a faulty light and a good one and unplug the head loom from the doggy one and plug the loom into the board of the good light and see what happens if it works fine then it could be a dry joint on the board of the faulty one, if it doesn't make a difference.

You may find that there is Swarf inside the steppers and either need cleaned or replaced. Joe

Link to comment
Share on other sites

  • 1 year later...


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.