Jump to content

Muting call beeps on Altair WBS-202 Basestation

Recommended Posts

Hi guys!


I have an Altair WBS-202 base station with WBP-210HD belt packs.


I'm sure it hasn't done this before but now when I press call on either the base station or belt packs the base station beeps. I tried pressing the "Remote Mute Buzzers" button, and while this silences the beep, it seems to make the base station constantly call on both channels.


Any ideas?



Link to comment
Share on other sites

Agree with J Pearce - might be the termination buttons but this usually means the units constantly call and if the beep mute is in it only flashes/vibrates.




Other than that it is certainly not something I have come across - Mine work as expected.

Suggest you contact Altair technical who are generally excellent - Be aware though of their summer shutdown which might delay a response (not sure when it is, think it is later in August).



There was a firmware update a few months ago for some of the HD versions, so depending on the ago of your units it might sort it - But odd if its only just started.

The firmware issue was to deal specifically with units which froze during operation and only on the packs rather than the basestation. Again tech were great at providing the software to update the firmware etc...


Might just be worth de-registering and re-registering units to the base station, but as mentioned they should just work as is.

Link to comment
Share on other sites

Perfect, that was exactly what it was. Buttons must have been caught when it was last packed away!


Thank you so much!




Constantly calling on all channels sounds like a termination fault.

Check the master/slave switch on the rear of the unit.


The mute all buzzers button should work as it is described to work.




Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.