Jump to content

DualHead2Go problem ?


Recommended Posts

Video and Projection etc. is not my natural domain but in recent months I have become more involved with it. I have a Matrox DualHead2Go(analogue) that cannot see either of two GeneTouch GT42MAZ screens. Every other screen or projector I have tried is OK. I have tried this with both a MAC and a PC with the same result. The screen displays 'No Cable' message and as far as the computers are concerned there is no Screen attached. I have connected the both GT42MAZ directly to both computers and all is how it should be so I'm guessing the Matrox unit doesn't see the screen for some reason or another. Has anyone else encountered this or a similar problem ?
Link to comment
Share on other sites



I've used a number of Matrox products, dual head's and triple head's in the past..


In my experience the analogue dualhead's are pretty much Plug and Play.. Are you using Matrox PowerDesk to manage your screens etc?


If you need a direct line to Matrox I have always found their support very helpful, they're based in Canada:

Worldwide Technical Support in English language:

Matrox Graphics Inc.

Telephone: +1 (514) 685-0270

Hours of operation: Monday to Friday

9:00 AM to 5:00 PM (UTC/GMT -5 hours)

If you use Google Hangouts to call then it is free! I have found Kevin in their support centre to be incredibly helpful in the past.


edit: removed poor html from info copied from their website

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.