Jump to content

Qlab & Lanbox MIDI Show Control Help


Recommended Posts



I am trying to run my lighting desk via MSC.


My lighting desk is a Lanbox Lcx, running LCEdit software.


I have connected MIDI cables IN and OUT via usb to my Mac.


My Lanbox is connected via USB, and running the lights via DMX.


When I run a MSC cue via Qlab, I get no response from the Lanbox. The settings I am using are as follows:


Qlab (pro version)


Patch 1 - USB MIDI port 1

Patch 2 - USB MIDI port 2




ID: A, MSC: 1


Any ideas on what im doing wrong? Screenshots below













Link to comment
Share on other sites

Change the device ID to A in the Go command?
Technically' date=' "A" is not a valid value for a Device ID (it must be numerical 'tween 0 and (if memory serves) 63). Typing "A" (or any other non-numerical value) into QLab in this input field will result in QLab rejecting it and replacing it with "0". That said, alister, I do believe you're onto something.


Kim, if you hover your cursor over the box captioned "MSC" in LCEdit, I believe you may get a popup that tells us that [I']this[/I] is the MSC Device ID that the "layer" will respond to. (The "ID" field here is apparently the name of the layer.) So could you try doing what alister suggests, but changing the "Device ID" field within QLab to "1" instead of "A" or "0"?


After that, I'd think it would be a case of determining the cuelist and cue number. From screenshot 3, it appears you're in cuelist 21 and you don't appear to have a cue 1.1 in that list.


Hope this helps.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.