Jump to content

Mackie SRM1801


Recommended Posts

Good Morning / Afternoon - After checking time.


I have been presented with a mackie SRM1801 which is showing some input issues. the unit is out of warranty so I have been asked to see what I can do.


The unit is showing issues with the inputs as when you plug in the XLR to inputs the signal light is showing even with no output from console.

When signal is sent to the unit the O/L light comes on straight away limiting the output massively of course for protection.


I have tried using a different source for the input and is shows the same issues. swapped cables everything included iPhone straight into unit.


upon opening the unit I found that on the input board there is a Jumper J4 which is not connected. the detail next this instructs compression.


My thoughts are --- should there be a jumper here to enable this.


but then the input should not show the signal with out there being any.


will await some response to see what someone elses thoughts are or if anybody was able to fix this them selves or if I need to just order a new amplifer unit.





Link to comment
Share on other sites

Do you get any output at all?

If so, the amp and speaker *might* be OK, but I'm not sure, just curious whether you can hear anything.

I don't think it is that jumper, since the unit worked normally before, w/out jumper.

Just a thought - it looks like something is oscillating, which could be the amp or whatever filter networks are before it. In that case you would get a 50/60 Hz hum and the amp would be getting hot.

Keep us posted and good luck!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.