Jump to content



Recommended Posts

Hello, need some help! I'm not an expert and I am getting really frustrated.

Just bought twelve SKYTEC 196 LED PAR56 LIGHTS... (http://www.skytronic.co.uk/product/index.php?s=151.685)

I also bought a SKYTEC controller with 16 channels per fixture and 192 channels in total. It can take up to 12 fixtures. (http://www.skytronic.co.uk/product/index.php?s=154.059).


I tried connecting all the LEDs... used DMX cables to connect one to the other. All of the addresses are correct. Tried controlling the lights and no response what so ever. Tried several times but nothing.

I then tried to control 1 LED on its own using the controller. Address was set to 1. Therefore dip switch 1 is ON. Nothing happened! What I did notice was that if address 10 was put on... all lighting rings of the LED PAR CAN switch on. Also... there is a small green and small red LED on the back of the PAR CAN. The Red one lights up when its switched on. However, the green one only lights up when dip switch 10 is switched ON. Another thing I've noticed is that if I then try to disconnect the DMX cable to the controller when dip switch 10, the green LED on the back is on and the light its self is on, both the LED PAR CAN and the green LED on the back switch off. Also tried playing with the blackout button on the controller but nothing. I select the correct fixture and play about withe the channels but no response.


Manual says nothing but some information about the addresses. Does not say that dip switch 10 should be switched on to activate DMX mode. The DMX controller manual is the same. Just tells me about creating scenes and programs.


I thought it should have worked the second I connected the lights. Am I missing something?


Please help!

Link to comment
Share on other sites

From the LED par manual it looks like dipswitch 10 is just for addressing, so shouldn't be on unless you want to address it to channel 512, but on the controller (according to the manual on the page you linked to) the controller has a DMX polarity switch. This maybe your problem. Try switching it and see if it works then.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.