Jump to content

Old trackspot won't turn on


Recommended Posts

I have an old trackspot that has seen better days. Have 4 in our rig but one just has stopped working. It does not power up at all. I've tried replacing the fuses but still no joy. The green signal LED has snapped off the circuit board but I can't imagine that is going to make much of a difference. Any ideas would be much appreciated!



Link to comment
Share on other sites

you may want to buy your self a multi meter... so you can check to see where the power is getting to I.e if it not getting down the cable, you may need to replace the cable.


Try and follow the power from plug right through I unit with the multi meter and see if you can find the problem


Hope all that makes sense


Good luck :stagecrew:

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.