Jump to content

Mac500 FbER help needed


Recommended Posts

Recently got hold of a very cheap Mac500 that has seen Better days. It had MANY problems including Knackered motors, these had been stripped and re-assembled incorrectly, missing driver chips, knackered Gobo and colour wheel sensors and other problems. Have managed to re-build the unit and it now works Fine. However I am still getting a FbER on the display, which is the Opto sensors for Pan and Tilt. I remove each of the sensors in tearn and still get the same error so it is to do with Both sensors and not just one of them. I have the sensors on my bench and it looks like the sensors have been replaced on the board. However I feel the sensors may have been put in the wrong way round but there is no markings on the circuit boards to indicate the polarity of the sensor on the board. Can any one help. Also I do not have any circuit diagram for this sensor circuit. Can anyone help with a Circuit diagram for the complete Mac500 or just for the Pan/Tilt sensor circuit. THANKS in advance.
Link to comment
Share on other sites

The pan and tilt page from Mac 500 service manual




4 . 9 . 1 PA N O R T I L T F A I L S T O R E S E T ( PAER, TIER)

• Defective indexing switch: The reset fails if the pan and/or tilt reset switches fail to close. Check the connections. Close the

switch manually and check for continuity across the contacts.

• Improper pan reset switch adjustment: Refer to section 3.8.

4 . 9 . 2 FE E D B A CK E R ROR ( FbER, FbEP, FbET)

• Dirty optical sensor: The pan and tilt position sensors are optical and must not be obstructed by dust or dirt. Clean the sensor

with compressed air.



Hope it might help



Link to comment
Share on other sites

THANKS, Have done that and still waiting on a reply, Hoped someone here may have the solution a bit quicker.


Thanks Doug. The Switches are OK. Just the optical do not sense. Have already blown them with my tin of compressed air and still the same fault. I am sure the person who had unit before me has messed around with it and done soethin wrong. Have also checked the continuity from the sensors to the board and wires are OK. So is a sensor problem or the receiving part on board. But I am sure sensors could have been installed the wrong way round to the board as soldering on the sensors is CRAP. But I do not want to turn them round if they are correct, as this could damage them. So is one of 2 problems, Sensor, or receiving circuit. So a circuit diagram of the P/T Optical circuit is the only way to fix. So if any one can help, it would be GREAT !!! Still waitin on reply from Martin, but I think they may be reluctant to give out circuit diagrams, they will probably say send it to a Service engineer. If I had done that on this unit already it would have cost me more than bying a new one.

Link to comment
Share on other sites

Have you checked the wiresets that that run from the main PCB to the opto sensor boards.


Also check that all the teeth are present on the opto encoder wheel that the runs through the middle of the sensor.


Lastly if you have come to the conclusion that these sensors have been bodged al little why not jus buy new ones they are only a few quid.

Link to comment
Share on other sites

Yep have checked all the cables, checked the wheels, they were 1st thing to do.

So is down to the sensors or the receiving circuit.

As this Mac has been mistreated in the past by an Amature Tech then I would

think sensors could be wrong way round.


I want to eliminate everything. A circuit diagram would help if any one has one.


I am ordering a new sensor board as well so I have a reference.

As it looks like a circuit diagram is as rare as Rocking horse S---.



Link to comment
Share on other sites

  • 3 weeks later...
I personally would change the micro switches before you change anymore sensors


With the MAC units I have seen the little optical encoder rigs fail quite a bit. If it isn't the driver chip, motor, or wiring harness, that is my next suspect.



Link to comment
Share on other sites

  • 4 years later...

Hi Just read this and I had the same problem on a Martin Mac 250! The strange thing about it was that it only happened when the lamp was on! I spent a hell of a lot of time changing bits over, luckily I had another mac to take the bits off that worked. It's good to have two bits of kit to A B. :rolleyes: In the end after swapping over nearly everything I discovered it was the thermal cut out switch in the lamp circuit. What was happening was the thermal cut out had started to arch in side quite possibly due to people not lamping off and not letting the unit cool down before switching the unit off - just wear and tear I would think on the bi metallic strip inside the thermal cut out. The thermal cut out is above the lamp and operates if the fan fails. Arching in the Mac 250 send spikes down the power lines and it upsets the microprocessor hence FBER and sometimes other errors as well like LERR. If you do get a problem on any mac see if the unit works OK with the lamp off.


Hope this helps someone out there.

Link to comment
Share on other sites

Hi all,


Just to continue a common trend, got some issues with our 500's!


Had 3 in bits today - one had a completely dead shutter, was a blown Dim chip, and that was replaced so all good.


The others:


1) Power on and the fans come on, you hear the "clunk" as it is about to start moving and self testing, but then nothing. The fan in the head powers down, and it just stays in RST forever. The fan in the base works. Power to motors. Have given it a good clean all along the main PCB etc, but no luck so far. Just surprised no errors come up or anything.


2) The other, everything works except the pan and tilt (making it less than useful as a moving light!). I've had a reading of around 4.6v (at home now and can't remember exactly) on all P/T motors, so its not the looms. I'm gonna swap out the Pan and Tilt chips tomorrow for the above unit, to see if that has anything to do with it. (it is essentially exactly the same problem as the one I fixed above, except with Pan and Tilt, rather than shutter). The motors have a bit of resistance in them if I manually move the head when powered up, but nothing like it should be.


Just wondering if anyone else has any other suggestions? My colleague has all the service guides for them, with layered breakdowns of all the PCB's... I suppose what I am kind of looking for is a central "chip" which drives the others to replace... but not found one. Unfortunately he can't currently find the service guides!


Current thoughts is to swap the pan/tilt chips,then motors in case they have all died at once, then the main PCB, then I guess transformers etc in case its a power issue. Quite happy to have only one of these 2 units working, as the unit with the shutter issue was originally destined for spares anyway so quite useful! Why are these things such a pain in the neck!!





Link to comment
Share on other sites

Hi Tomas,


With your first MAC 500 that will not come out of reset. Have you taken the head cover off and have a look to see if the colour wheels or gobo wheel is constantly rotating. If so then the sensor for that wheel is stuck on. When a MAC powers up it looks at all the hall sensors to see if any are on, if they are it will rotate the wheel to clear the sensor, if the sensor is faulty and stuck on regardless of the magnet being underneath or not it will sit there rotating the wheel indefinitly untill the senosr turns off.... this may be your problem

Link to comment
Share on other sites

in regards to the OP in my experience when you get a general feedback error it tends to be more board related. I had the same issues a few months ago and I phoned martin and they talked me through absolutely everything and then sent me a full circuit diagram. Very helpful, I think in the end it turned out it was a dry join in a very obscure place.
Link to comment
Share on other sites

I'm suspecting a board error with this unit.


Stuart - it basically clunks into "pan test", but immediately anything physical shuts down... except the screen still says RST and the base fan is whiring. It's almost as if it has crashed!


Ah well, a bit of investigation, and swapping bits between units beckons I think!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.