Jump to content

Fat Fog Fixture control not working advice please


Recommended Posts

Fat Frog working OK except for the Fixture control section is non functional.


I am hoping that I have missed something in the operating procedure but feel it is a hardware issue.



I have replaced the battery however it was not working prior to this.



Anyone have an idea?

Link to comment
Share on other sites

Depends on what you mean by non-functional. If it is the whole fixture panel completely dead, there is a single ribbon cable connecting it to the main board IIRC which would be worth checking in case it has become unseated?


Has it worked before or is this the first time you are trying to patch a fixture? If so, it is a long time since we had an FF but have you tried patching one of the dimmers as a fixture and check if that works?


Also, remember that if you are patching LEDs you normally need both intensity AND colour before they light up.


That's about all I can think of.

Edited by vinntec
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.