Jump to content

Skytec smoke machine


Recommended Posts

Hi there, I am new to this so please go easy on me :)

I have borrowed a skytec 700w fog machine from a friend for a childs halloween party, but unfortunatly the machine doesnt seem to want to work! the friend told me it has worked but when he tried it for some reason it no longer does.

I switched the machine on and it takes about 4 mins to heat up, then the little green light comes on, I press the button and I hear a click and hear what I believe to be the pump working, but still nothing comes out! I have taken the copper connecting pipe off and that is clear. does anyone have any ideas? Thanks


A concurrent post has been automatically merged from this point on.


Just to update everyone, I took the pipe from the pump off the heater block and filled the tank with deironised water and switched it all on and when it was ready I pressed the button and nothing came through the pump! Now does this mean that the pump is knackered or does the pump have to be connected to the heater block to form a vacumn for it to suck the fluid through? or should it have pumped the fluid through when the button was pressed anyway? Thanks


Link to comment
Share on other sites

If that doesnt work, the pumps can be taken apart. If it is gummed up then cleaning it out might help. Just remember how it goes back together :)


A blockage somewhere seems the inevitable fate of all cheap smoke machines. If you cannot fix it, you can buy replacement pumps for about £10-15. But it may be worth getting a whole new machine as they're only £30-40 new. You might even be able to get something on fleabay for the broken one if someone else thinks they can fix it.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.